RSS
 

Archive for April, 2011

APODViewer7 2.1 released

29 Apr

This is a minor fix to the application that corrected two bugs.  They are:

  • Corrected the first of the month bug.  Previously if executed on the first of the month and the app was set to load the latest month on load, no data would be produced on screen.  The workaround was to go back a month then return
  • The HTML descriptions for the images when referencing links from the APOD site were set as relative links from the APOD server.  When clicked the browser would only show what the link name was.  This was corrected by expanding the link to what server your mirror settings were set to.

Looks like I submitted the APODViewer7Pro’s title incorrectly, it reverted back to the original title.  This will only be noticeable when viewing it in the marketplace.  I’ll be submitting a new update today to correct that.

 
 

APODViewer7 First of the month bug

01 Apr

For those of you wondering whats going on with the APODViewer7 app today, there is a bug that preventing the current month from being shown.  On load it is attempting to load the current month and just showing ‘Latest’ in the pivot and not showing any data.    The reason for this is the event that goes and downloads the data only does so if the date changes.  It defaults to current date, as of now April 1st 2011.  When the app fires up it updates this value with the first of the current month being viewed.  If the same date is sent to control it does not fire the update event. 

I have this bug corrected, I will get it submitted and have the app updated before this occurs again next month.  For now, the workaround is to select the previous month and then back to the current month.  This forces the app to load the correct data.  The problem will go away tomorrow.  Sorry for the problems!

 
1 Comment

Posted in WP7